Help with Creator's Toybox

Discussion in 'Poser' started by FreyrStrongart, Feb 8, 2019.

  1. FreyrStrongart

    FreyrStrongart Adventurous Contributing Artist

    I just got Creator's Toybox but I have problems making it work. I sent it to Python script but the code that was saved was totally wonky, and I had to replace it with the proper : instead of \.


    poser.DefineScriptButton(1, ":Runtime:python:poserScripts:philC:Wardrobe Wizard P11:Wardrobe Wizard Menu.py", "Wardrobe Wizard")
    poser.DefineScriptButton(2, ":Runtime:python:poserScripts:Netherworks:ToyBox Control:ToyBox.py", "Creator's ToyBox")
    poser.DefineScriptButton(3, ":Runtime:python:poserScripts:Utility:utilityButtons.py", "Utility Funcs")
    poser.DefineScriptButton(4, ":Runtime:python:poserScripts:SampleCallbacks:callbackButtons.py", "Sample Callbacks")
    poser.DefineScriptButton(5, ":Runtime:python:poserScripts:RenderControl:renderButtons.py", "Render / IO")
    poser.DefineScriptButton(6, ":Runtime:python:poserScripts:MaterialMods:materialModButtons.py", "Material Mods")
    poser.DefineScriptButton(7, ":Runtime:python:poserScripts:printInfo:printInfoButtons.py", "Print Info")
    poser.DefineScriptButton(8, ":Runtime:python:poserScripts:CreateProps:propButtons.py", "Prop Samples")
    poser.DefineScriptButton(9, "", "...")
    poser.DefineScriptButton(10, "", "...")



    Now I can see Toybox in the Poser Script controls. But when opening it I get the message

    Traceback (most recent call last):
    File "\Runtime\Python\poserScripts\Netherworks\ToyBox Control\ToyBox.py", line 24, in <module>
    NameError: name 'NWS_ToyBox' is not defined

    This also happens when I try to open any of the Toybox files via the Scripts Menu. Toybox, the bit that is in poser by default, also never worked for me.

    Any idea what the problem may be?
     
    Last edited: Feb 8, 2019
  2. Ken1171

    Ken1171 Distinguished Contributing Artist

    I have been using Creator's Toybox for years, and it has always worked for me. This sounds like an installation mishap. Just contact Alisa for proper support.
     
  3. Miss B

    Miss B Drawing Life 1 Pixel at a Time CV-BEE

    I just tried opening each of the goodies in the Toybox with no problems at all.

    I don't know if you're on a PC or a MAC, but if on a PC, and you go to Runtime > Python > poserScripts > Netherworks > Toybox Control, do you see 2 python scripts? One is called Toybox.py, and one called _nwsToyBox.pyc. I'm not familiar with how he set up the script, but I'm assuming, from what you stated above, Toybox.py is looking for NWS_ToyBox, but the second script is actually named _nwsToyBox.

    I've done scripting in a lot of langues, but not Python, so I'm not sure if that's the problem. Like Ken, I also bought it a long time ago, when the RDNA store was still open, so not sure if there were any changes made to it when he brought his products here to HW3D.
     
  4. Janet

    Janet Extraordinary Contributing Artist

    Yah I have it also and really like it. Works great.
     
  5. FreyrStrongart

    FreyrStrongart Adventurous Contributing Artist

    I changed the naming call but i got the same message. I reloaded the whole thing in case something is off and it still doesn't work. I used to have the poser content in a sub-folder... so basically had two runtimes but I have put everything into the base runtime now but still got the same problems. Every single item in the script list gives me this error message when I try to load it.
     
    Last edited: Feb 10, 2019
  6. Ken1171

    Ken1171 Distinguished Contributing Artist

    Have you tried reinstalling the script, but this time with administrator credentials?
     
  7. FreyrStrongart

    FreyrStrongart Adventurous Contributing Artist

    I have only one account, the admin, since I am the sole user of the comp. So that can't be the problem. I deleted all the files, cleaned the Poser11 folder (poser insists on creating a new poser 11 content folder in the original base but it's empty)... reinstalled from zip but the message is always the same. Whatever program I try to open via the scripts always gives me the error message in line 24 for THAT program.
     
  8. Steve.M

    Steve.M Admirable

    Hi,

    I have just got Toybox and all appears to be O.K.

    Please Note: If you have installed Poser on windows to its default location in program files (or in another protected location), you will need to run Poser with Administrator privileges (RMB the poser icon on desktop and select "Run as Administrator"). Otherwise most of the tools in Toybox will not work correctly.

    Even though you are logged in as Admin, Poser will not by default run with that privilege (due to UAC).
     
  9. Ken1171

    Ken1171 Distinguished Contributing Artist

    In addition to what Steve said above, please remember that the Windows UAC is NOT what it seems. Even if you log in as administrator on an administrator account, this will NOT grant you "administrator" rights in everything you do. I know this doesn't make any sense (especially if you are coming from Linux), but that's how it is. Whether if you have logged in as an administrator, you STILL need to manually grant admin rights to everything you want to run as such. For example, if you open a command prompt box (or PowerShell), by default it will NOT have admin credentials. And everything you do with File Explorer will still require you to manually grant admin rights every time you need it. All this is true even if you disable Windows UAC. You still need to manually grant admin credentials every time.

    I have to say it because most people believe that running Windows on an administrator account would always automatically allow everything, but that's not how it is. Over here, I have installed Poser in its own drive (not the C:\ system one) exactly because I don't want to have to deal with UAC permissions every time.
     
  10. FreyrStrongart

    FreyrStrongart Adventurous Contributing Artist

    ok... so I set up the admin account and loaded the creator's tool kit via the admin user. Doesn't do a thing. I still get the same calls as before. Looks like something with that kit is not working with my poser.
     
  11. Miss B

    Miss B Drawing Life 1 Pixel at a Time CV-BEE

    This is why I never install any of my apps (2D or 3D) in Program Files. That changed several Windows versions ago.
     
  12. FreyrStrongart

    FreyrStrongart Adventurous Contributing Artist

    nor do I. They are installed on an external drive... that admin thing should actually not matter. So I wonder if it isn't actually a problem of the program. I have tried everything to make it work
     

Share This Page